Reply to post

Silent installation issue

Author
rydiand
New Member
  • Total Posts : 4
  • Scores: 0
  • Reward points : 0
  • Joined: 2011/03/21 11:16:16
  • Status: offline
2011/03/21 11:29:19 (permalink)
0

Silent installation issue

Is it possible in a silent installation to set a switch that will force close down of a running version of HyperSnap ?
This is the command we use today: HS6Setup.exe -s -runafter -autostart -allusers -nodeskico
When I run it it tell me that one instance of HyperSnap is running and ask me if it should try to close it. I would like to have a switch that forces a close of the open instance.
 
Please provide this additional data: 
Exact HyperSnap version in use (from Help/About menu): 6.90.04
Windows version in use: WIN XP 

3 Replies Related Threads

    Support
    Administrator
    • Total Posts : 4445
    • Scores: 26
    • Reward points : 0
    • Joined: 2010/11/22 17:14:33
    • Location: PA USA
    • Status: offline
    Re:Silent installation issue 2011/03/21 11:46:11 (permalink)
    0
    I would have to modify the installer program to do this without prompting or add an extra switch. Please note however, that if the user is editing some image or has some unsaved captures in a running HyperSnap window, her work would be lost with such "silent" upgrade...
     
    Greg
    rydiand
    New Member
    • Total Posts : 4
    • Scores: 0
    • Reward points : 0
    • Joined: 2011/03/21 11:16:16
    • Status: offline
    Re:Silent installation issue 2011/03/22 03:04:47 (permalink)
    0
    That is a risc I'm willing to take. We've an installation program that the installation is wrapped in.
    This installer can wake the computer during the night, install HyperSnap and then close down again. But that won't work if a key need to pushed because an instance of HyperSnap is running.
     
    Torben
    Support
    Administrator
    • Total Posts : 4445
    • Scores: 26
    • Reward points : 0
    • Joined: 2010/11/22 17:14:33
    • Location: PA USA
    • Status: offline
    Re:Silent installation issue 2011/03/22 17:44:06 (permalink)
    0
    I looked at the installer code, and I see that at some point I programmed it so that if -s or /s command line parameter is not the very first parameter following program name, then it does not ask about shutting down any running instance of HyperSnap - just shuts it down silently. So you could modify your command as follows:
     
    HS6Setup.exe -autostart -allusers -nodeskico -s
    or if you would not have any other arguments to add, you could use:
    HS6Setup.exe -s -s

    effectively repeating -s parameter for "super-silent" installation. This should do what you need. Please note that I removed also -runafter, which you probably should not use at all (see the other thread about reboots).
    Greg
    Jump to:
    © 2014 APG vNext Commercial Version 4.6