Reply to post

Hot!Quick Save path keeps resetting

Author
vertigoelectric
User
  • Total Posts : 1
  • Scores: 0
  • Reward points: 0
  • Joined: 2011/09/17 11:46:30
  • Status: offline
2019/02/27 19:31:27 (permalink)
0

Quick Save path keeps resetting

I've been using HS for years, but only the past few months have I had this issue.  I keep losing the path in "Capture Settings > Quick Save" so that captures are not being saved in the folder I specified.  This seems to happen at random as I've not yet discovered a cause.
 
The only possible thing I can think of is IOBit Advanced SystemCare.  I'm wondering if there's a chance HS keeps this setting saved in a place where ASC is doing its cleaning operations and is getting lost that way.  Although, I don't seem to be losing any other settings, so why only this one?
 
Where is this setting saved so I can make sure it's not lost?  Is it a registry key?

7 Replies Related Threads

    Admin
    Administrator
    • Total Posts : 275
    • Scores: 6
    • Reward points: 0
    • Joined: 2010/11/22 00:00:00
    • Location: USA
    • Status: offline
    Re: Quick Save path keeps resetting 2019/02/27 20:19:13 (permalink)
    0
    Hi,
    I have never seen such problem, nor heard similar complaints from other users. HyperSnap keeps its settings in Windows system registry, under the following key:
     
    HKEY_CURRENT_USER\Software\Hyperionics\HyperSnap 8
     
    There, under QuickSave key there is FileName value of type REG_SZ (text string), containing the directory and file name for Quick Save operations. Other Quick Save options are saved there as well. Note that HyperSnap saves options to the registry when you exit the program, if you keep it open all the time and then shutdown the system without exiting HyperSnap, it may not have the chance to save what it needs to into the registry.
     
    Greg
     
    vertigoelectric
    User
    • Total Posts : 1
    • Scores: 0
    • Reward points: 0
    • Joined: 2011/09/17 11:46:30
    • Status: offline
    Re: Quick Save path keeps resetting 2019/02/27 20:31:27 (permalink)
    0
    Thanks for the quick reply.
     
    Hmmmm well I do keep HS open all of the time, but I've exited/launched it several times as well.  It's possible that something is happening during exit or Windows shutdown that is causing that particular entry to become corrupted.
     
    If it happens again I'll check the registry entry to see what it changes to.
     
    When this happened earlier today, after I posted here, I searched my PC for my recent snap and found that it didn't actually save anywhere, so now it's not just an issue of them not saving in the right place, but not saving at all.
     
    Thanks again!
    vertigoelectric
    User
    • Total Posts : 1
    • Scores: 0
    • Reward points: 0
    • Joined: 2011/09/17 11:46:30
    • Status: offline
    Re: Quick Save path keeps resetting 2019/04/11 13:05:35 (permalink)
    0
    It happened again.
     
    I checked the registry and the FileName entry wasn't just changed... it was gone completely.

     
    I had to do some searching but I finally found where the files were actually being saved, and it makes no sense at all. 
    I found the files with only the incrementing numbers and no extension...
     

     
    ...but the weird part is that they're in a folder that has nothing to do with Hypersnap.  The path I set is:
     
    ...\My Documents\!! My Documents and Files\My Pictures\- Hypersnaps\
     
    but when this problem occurs it seems to be putting the files in one of these two folders:
     
    ...\My Documents\AHK Scripts\SYSTEM\
    ...\My Documents\AHK Scripts\SYSTEM\Startup&Shutdown\
     
    Obviously those locations don't mean anything to anybody else but me but it's just weird that Hypersnap would put the files there.  If no path is set I would usually expect it to default someplace like the root of My Documents, or the program's install folder.  Why my AHK Scripts\SYSTEM folder?  How does it even know that folder exists?
     
     
     
    Admin
    Administrator
    • Total Posts : 275
    • Scores: 6
    • Reward points: 0
    • Joined: 2010/11/22 00:00:00
    • Location: USA
    • Status: offline
    Re: Quick Save path keeps resetting 2019/04/11 15:33:28 (permalink)
    0
    I really don't know and don't understand what happens there. Could be that the system registry is somehow corrupt, or the file system is damaged, or other erroneous conditions exist on this device. Or maybe the problem is using "My Documents" folder, which under newer versions of Window is no longer a folder, but a "junction" pointing to the actual folder, usually at C:\users\user_name\Documents. I see strange things happen on my Windows 10 computer when I try to enter "My Documents" under my user name. It is not shown by Windows File Explorer, by under the Command Prompt I can use
     
    cd "My Documents"
     
    and the command prompt seems to enter it, but when I try to open an explorer window there, I get message "C:\Users\greg\My Documents" is not accessible. A dir command there shows only "File Not Found". Simply avoid the aliases or "junctions" like "My Documents", "My Pictures" etc. which date to Windows XP and earlier era, and use real folder names.
     
    See also:
     
    vertigoelectric
    User
    • Total Posts : 1
    • Scores: 0
    • Reward points: 0
    • Joined: 2011/09/17 11:46:30
    • Status: offline
    Re: Quick Save path keeps resetting 2019/07/16 16:03:09 (permalink)
    0
    This is getting really annoying.  The "FileName" key in the registry keeps having its value cleared or getting deleted altogether.  I just updated to the latest version of HS8 to see if that fixes the issue but it did not.
    Admin
    Administrator
    • Total Posts : 275
    • Scores: 6
    • Reward points: 0
    • Joined: 2010/11/22 00:00:00
    • Location: USA
    • Status: offline
    Re: Quick Save path keeps resetting 2019/07/16 16:10:43 (permalink)
    0
    I really have no more suggestions beyond what I have already written in this thread. Just checked on my machine, the FileName value in the registry that I have set some time last week (and rebooted the computer many times since then, I shut it down nightly and start over in the morning), is still present. If you are still using "My Documents" folder, please stop using it, and instead use simply Documents
    vertigoelectric
    User
    • Total Posts : 1
    • Scores: 0
    • Reward points: 0
    • Joined: 2011/09/17 11:46:30
    • Status: offline
    Re: Quick Save path keeps resetting 2019/07/16 16:17:32 (permalink)
    0
    I appreciate it anyhow.
     
    The actual folder is a subfolder of the My Documents library, like so:
    D:\!! SYSTEM DATA !!\My Documents\!! My Documents and Files\My Pictures\- Hypersnaps
     
    However I tried using a junction at D:\Hypersnaps\ and that didn't fix the problem either.  Just now I created a new junction at C:\Hypersnaps\ to see if having it on the system drive makes any difference.  If the problem still occurs, I'll create a "real" folder at root level completely outside of My Documents to see if that helps at all.
     
    It's hard for me to believe that this is caused by the way Windows 10 handles the My Documents folder.  I've been using HS with Windows 10 for years and only relatively recently has this problem started to occur.
    Jump to:
    © 2019 APG vNext Commercial Version 5.1