Reply to post

Hot!multiple monitors - sometimes print screen key does nothing

Author
cat84521
User
  • Total Posts : 0
  • Scores: 0
  • Reward points: 0
  • Joined: 2017/10/28 14:41:32
  • Status: offline
2017/11/07 10:01:16 (permalink)
0

multiple monitors - sometimes print screen key does nothing

I am running Windows 10, build 15063, with Hypersnap version 8.14.00 (64-bit).
 
I currently have 2 monitors on my system.  The primary monitor is on the right, and the secondary monitor is on the left, so it has a negative X co-ordinate.
 
Sometimes the print-screen button on my keyboard does nothing, Hypersnap does not respond at all.  There is no sign that Hypersnap has even registered a key press.  I think the dual monitors are a factor, but I have not been able to pin down the pattern yet.  Other times print-screen works correctly, and captures the entire active monitor, which is the monitor the mouse pointer is currently on.
 
Are there any known bugs like this?  Where should I start looking for clues, and what information will help to explain what is happening?

9 Replies Related Threads

    Admin
    Administrator
    • Total Posts : 275
    • Scores: 6
    • Reward points: 0
    • Joined: 2010/11/22 00:00:00
    • Location: USA
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/07 10:15:24 (permalink)
    0
    What settings exactly do you have selected on "Screen Capture Hot Keys" screen, when you click Capture ribbon tab - "Hot Keys" button? Specifically, does the "Enable Hot Keys" field have a check-mark in it, and what _exactly_ is selected in the "Print Screen Key Handling" field?
    cat84521
    User
    • Total Posts : 0
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/10/28 14:41:32
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/07 15:59:04 (permalink)
    0
    Enable Hot Keys = On
    I keep this On, at all times, even though I have customised the hotkeys themselves, to avoid conflicts with other programs.
     
    Print Screen Key Handling = Capture Full Screen
     
    which, on my system, captures the "current" monitor, and only the current monitor.  In Windows display settings, it is currently listing 2 monitors, as separate monitors, which is correct.  When I finish moving house I will be back to 3 physical monitors.
     
    When the problem is happening I found bringing HyperSnap to the front, going to the Capture tab, and pressing the "Full Screen" button worked correctly, even though pressing the PrintScreen keyboard button had no effect.
     
    Once the PrintScreen button is working again, it does not seem to matter which screen I have HyperSnap on.  The current monitor is always the one with the cursor, even if the current program (window) with keyboard focus is on the other monitor.
     
    One other setting change I have made is to set:
     
    Capture settings -> Capture -> Delay time before the capture = 0 milliseconds
     
    I have been using HyperSnap for years, and have it set to load on windows startup, and also to load minimised.  I have only noticed this problem with screen captures not being triggered in the last few weeks, which suggests it is a recent problem.  Unfortunately vague.
     
    From what I have noticed, when I first turn on the computer HyperSnap is loaded, but is not responding to keyboard shortcuts.  Once I do "something", perhaps related to moving HyperSnap between monitors, it starts responding normally again.  I have only just discovered this though, I actually thought HyperSnap was not responding to any keyboard shortcuts at all, regardless.  Which was odd, since I could set a new shortcut in the hotkeys settings, and they were picked up and recorded by the dialog.
    Admin
    Administrator
    • Total Posts : 275
    • Scores: 6
    • Reward points: 0
    • Joined: 2010/11/22 00:00:00
    • Location: USA
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/07 18:13:55 (permalink)
    0
    It could be that another program is intercepting PrintScreen key when it's not working in HyperSnap. One user - or was it you? Can't tell with Forum aliases - wrote to me in email today, that he figured out Print Screen problem, in his case it was caused by Dropbox app, specifically by the setting to enable the option "Share screenshots using Dropbox"
    cat84521
    User
    • Total Posts : 0
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/10/28 14:41:32
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/08 10:08:24 (permalink)
    0
    Nope, not me.  I had no idea the dropbox app had a setting like that...  Just found it, and the setting is already turned off.
     
    It makes sense that some other program is capturing the print screen event, but from memory, when this is happening, none of my mapped keyboard shortcuts for HyperSnap are working.  I need to re-check this.  I know I am not fixing the problem by closing and re-opening HyperSnap, or closing any other running programs.
     
    Is there an easy way to see which program is currently listening for the Print Screen key?
    Admin
    Administrator
    • Total Posts : 275
    • Scores: 6
    • Reward points: 0
    • Joined: 2010/11/22 00:00:00
    • Location: USA
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/08 17:22:14 (permalink)
    0
    There is no way that I know of - Microsoft in its infinite wisdom, failed to provide such information to other programs or users.
    cat84521
    User
    • Total Posts : 0
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/10/28 14:41:32
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/11 07:24:59 (permalink)
    0
    No surprise there, it was a bit of a long shot.  Sometimes when trying to set up keyboard shortcuts in programs, I am told that a given keyboard shortcut cannot be registered, since someone else is already listening for it.  That does not tell me where the conflict is coming from, but at least I know there is one, to go looking for.
     
    So I was wondering if something similar existed for the print screen key.
     
    I will just have to keep an eye on this.  For the last couple of days, no signs at all of the problem, typical.  I finally pinned down enough of a pattern to report it, and then it goes away.  I will keep an eye out for this, and see if it comes back again soon.
    cat84521
    User
    • Total Posts : 0
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/10/28 14:41:32
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/17 10:22:25 (permalink)
    0
    I have just encountered the problem again.  No obvious trigger, my machine has been running for a couple of days now, but not a massive up time.
     
    If I press PrintScreen then a screen capture of both monitors is taken, but Hypersnap is not involved or responding at all.  The only way I know something is happening is if I then paste the current clipboard into a program that will accept an image paste, then the screen shot turns up.
     
    Hypersnap is running, responding, and I can alt-tab to it.
     
    I am now going to describe all of my findings, documenting them as I go, in the hopes that something here will offer a clue.  Also, if I don't document as I go, the small details can get lost / confused.
     
    Keeping the mouse pointer on the primary monitor, I alt-tab to Hypersnap, which is also on the primary monitor.  Press PrintScreen, and Hypersnap responds, taking an image of just the primary monitor, which I am happy with.
     
    Keep Hypersnap in front and with focus, and move the mouse cursor onto the secondary monitor.  OK, now Hypersnap is responding, and taking an image of just the secondary monitor.
     
    Mouse back to primary monitor, Hypersnap behind my browser.  The browser is full screen, primary monitor only and has focus. Now Hypersnap is responding, it's taking an image of whichever monitor currently has the mouse pointer.
     
    Theory - after a certain amount of interacting with Hypersnap this problem goes away, in stages.
     
    I have now found a pattern!  With Thunderbird maximised on the second monitor, and given focus, with the mouse on the second monitor, Hypersnap works as expected.  With VMware Workstation 14.0.0 on the second monitor, again full screen, and with focus on Workstation, but not inside one of the VM's, Hypersnap is doing nothing.
     
    Go back and forward between the programs, and the behaviour is stable.
     
    Change to a currently suspended VM in VMware Workstation, and Hypersnap works normally, regardless of which monitor I am on.
     
    Change to an active and currently running VM in VMware Workstation, and Hypersnap does nothing, regardless of which monitor I am on.
     
    I can capture VMware Workstation, so long as some other program has focus, by moving the mouse onto the monitor with VMware Workstation and pressing PrintScreen.
     
    PrintScreen is actually working when VMware Workstation has focus, but focus has not been moved into a VM, even though Hypersnap does not respond.  Pasting the clipboard content shows the correct and expected image has been grabbed of both monitors.
     
    This may well explain the mixed results I have been seeing.  But this has to be a fairly recent problem, I have been using both VMware Workstation and Hypersnap together for years, and am always taking screen shots of the current state of one VM or anther.
     
    What further details can I provide to help pin all of this down?
    Admin
    Administrator
    • Total Posts : 275
    • Scores: 6
    • Reward points: 0
    • Joined: 2010/11/22 00:00:00
    • Location: USA
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/18 21:20:17 (permalink)
    0
    If you use a virtual machine in VMware or any other emulator, all the keys you press go to the virtual machine and not the host. HyperSnap cannot react to events that it is not notified about by Windows system. Maybe in VMware options you may set the way special keys are handled, but I'm not an expert on that product.
    cat84521
    User
    • Total Posts : 0
    • Scores: 0
    • Reward points: 0
    • Joined: 2017/10/28 14:41:32
    • Status: offline
    Re: multiple monitors - sometimes print screen key does nothing 2017/11/22 11:32:41 (permalink)
    0
    Sorry, I was not clear, it comes from trying to figure things out while they were happening.
     
    I had focus on the VM "host", but not inside any of the actual VM's themselves.  So no mouse or keyboard input was going into any of the virtual machines, it was all going to the host machine.
     
    If I run HyperSnap inside the virtual machine, then it works correctly, as expected, when keyboard commands are being sent into the VM, but does nothing while focus is on the VM host, still out in the host OS.
     
    I would not expect the program that has focus to effect PrintScreen handling, and Windows is taking a screen shot when I press PrintScreen, when VMware host has focus.
     
    I hope this makes more sense.
    Jump to:
    © 2017 APG vNext Commercial Version 5.1